Our website use cookies to improve and personalize your experience and to display advertisements(if any). Our website may also include cookies from third parties like Google Adsense, Google Analytics, Youtube. By using the website, you consent to the use of cookies. .

The DRA server is already registered” ERROR of Azure Site Recovery Provider Setup

I have recently been running a POC of Hyper-V 2012 R2 experimenting replicating several VM’s to Windows Azure (Site Replication) in the East Asia region. During the POC I was receiving connection issues from the Hyper-V host so I decided to remove the Azure Site Recovery Provider agent from the Hyper-V host and the configuration settings from within Azure so that I could start again.

Once I configured the Azure settings I then re-installed the agent but on this occasion I received the following error which I’d not seen before

Azure

Upon going through various troubleshooting steps I found that the uninstall had not completely removed the previous registry settings for the site replication vault which was causing me the problem.

This is the process I followed:-

1) Uninstall the existing Azure Site Recovery Provider from your system.

1) Open the registry editor tool (regedit)

2) Browse to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft

3) Find a Key named Azure Site Recovery

4) Delete it the entire folder

5) Install the Azure Site Recovery Provider for Hyper-V

This time the registration worked and my Hyper-V host appeared as a registered server within Azure.  At last I can carry on with the setup :-).

 

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.

Related Posts